CVE-2023-41890
Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. Prior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible.
Timeline
ID reserved
By GitHub_M
- 15 days later
· 15 days later
Published
- 13 months later
· 13 months later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N |
| NVDNVD · Modified | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N |
- EPSS (exploitation in 30 days)
- 0.75% · top 45% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: yes · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.5.
Weakness
Affected products
- affected < 1.0.3
- affected >= 2.0.0, < 2.9.2
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- NuGetKentor.AuthServicesGHSA-fv2h-753j-9g39 (opens in a new tab)
- NuGetSustainsys.Saml2GHSA-fv2h-753j-9g39 (opens in a new tab)
References (3)
- https://github.com/Sustainsys/Saml2/security/advisories/GHSA-fv2h-753j-9g39 (opens in a new tab)x_refsource_CONFIRMx_transferred
- https://github.com/Sustainsys/Saml2/issues/712 (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/Sustainsys/Saml2/issues/713 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-fv2h-753j-9g39 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-41890)Record last updated .