CVE-2023-46604
Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Exploited in the wild
CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Apache ActiveMQ Deserialization of Untrusted Data Vulnerability.
- Added
- 2 Nov 2023
- Fix due (US federal)
- 23 Nov 2023
- Used by ransomware
- Known
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| apacheCNA (assigner) | 3.1 | Critical10.0 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H |
| NVDNVD · Analyzed | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 100.0% · top 0.1% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: active · Automatable: yes · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 10.0.
Weakness
Affected products
Apache Software Foundation · Apache ActiveMQ
- affected 5.18.0 – < 5.18.3
- affected 5.17.0 – < 5.17.6
- affected 5.16.0 – < 5.16.7
- affected < 5.15.16
Apache Software Foundation · Apache ActiveMQ Legacy OpenWire Module
- affected 5.18.0 – < 5.18.3
- affected 5.17.0 – < 5.17.6
- affected 5.16.0 – < 5.16.7
- affected 5.8.0 – < 5.15.16
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.activemq:activemq-clientGHSA-crg9-44h2-xw35 (opens in a new tab)
- Mavenorg.apache.activemq:activemq-openwire-legacyGHSA-crg9-44h2-xw35 (opens in a new tab)
References (8)
- https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt (opens in a new tab)vendor-advisoryx_transferred
- https://www.openwall.com/lists/oss-security/2023/10/27/5 (opens in a new tab)x_transferred
- https://security.netapp.com/advisory/ntap-20231110-0010/ (opens in a new tab)x_transferred
- https://packetstormsecurity.com/files/175676/Apache-ActiveMQ-Unauthenticated-Remote-Code-Execution.html (opens in a new tab)x_transferred
- https://lists.debian.org/debian-lts-announce/2023/11/msg00013.html (opens in a new tab)x_transferred
- http://seclists.org/fulldisclosure/2024/Apr/18 (opens in a new tab)x_transferred
- https://lists.debian.org/debian-lts-announce/2024/10/msg00027.html (opens in a new tab)
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-46604 (opens in a new tab)government-resource
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- CISA KEV catalog (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-crg9-44h2-xw35 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-46604)Record last updated .