CVE-2023-48239
Nextcloud Server users can make external storage mount points inaccessible for other users
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. Starting in version 25.0.0 and prior to versions 25.0.13, 26.0.8, and 27.1.3 of Nextcloud Server and starting in version 20.0.0 and prior to versions 20.0.14.16, 21.0.9.13, 22.2.10.15, 23.0.12.12, 24.0.12.8, 25.0.13, 26.0.8, and 27.1.3 of Nextcloud Enterprise Server, a malicious user could update any personal or global external storage, making them inaccessible for everyone else as well. Nextcloud Server 25.0.13, 26.0.8, and 27.1.3 and Nextcloud Enterprise Server is upgraded to 20.0.14.16, 21.0.9.13, 22.2.10.15, 23.0.12.12, 24.0.12.8, 25.0.13, 26.0.8, and 27.1.3 contain a patch for this issue. As a workaround, disable app files_external. This workaround also makes the external storage inaccessible but retains the configurations until a patched version has been deployed.
Timeline
ID reserved
By GitHub_M
- 8 days later
· 8 days later
Published
- 19 months later
· 19 months later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 3.1 | High8.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H |
| NVDNVD · Modified | 3.1 | High7.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H |
- EPSS (exploitation in 30 days)
- 0.95% · top 39% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.5.
Weakness
Affected products
nextcloud · security-advisories
- affected >= 25.0.0, < 25.0.13
- affected >= 26.0.0, < 26.0.8
- affected >= 27.0.0, < 27.1.3
- affected >= 20.0.0, < 20.0.14.16
- affected >= 21.0.0, < 21.0.9.13
- affected >= 22.0.0, < 22.2.10.15
- affected >= 23.0.0, < 23.0.12.12
- affected >= 24.0.0, < 24.0.12.8
References (3)
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-f962-hw26-g267 (opens in a new tab)x_refsource_CONFIRMx_transferred
- https://github.com/nextcloud/server/pull/41123 (opens in a new tab)x_refsource_MISCx_transferred
- https://hackerone.com/reports/2212627 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-48239)Record last updated .