Back
CVE-2023-49299
Apache DolphinScheduler: Arbitrary js execute as root for authenticated users
High8.8EPSS 1.4%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9. Users are recommended to upgrade to version 3.1.9, which fixes the issue.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Modified | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 1.4% · top 27% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.8.
Weakness
Affected products
Apache Software Foundation · Apache DolphinScheduler
- affected < 3.1.9
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.dolphinscheduler:dolphinscheduler-masterGHSA-v7hg-77v9-2445 (opens in a new tab)
References (3)
- https://github.com/apache/dolphinscheduler/pull/15228 (opens in a new tab)patchx_transferred
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm (opens in a new tab)vendor-advisoryx_transferred
- http://www.openwall.com/lists/oss-security/2024/02/23/3 (opens in a new tab)x_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-v7hg-77v9-2445 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-49299)Record last updated .