Back
CVE-2023-5159
A User Manager role with user edit permissions could manage/update bots
Low3.8EPSS 0.43%
- Published
- Updated
- Reserved
- Assigned by
- Mattermost
Description
Mattermost fails to properly verify the permissions when managing/updating a bot allowing a User Manager role with user edit permissions to manage/update bots.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| MattermostCNA (assigner) | 3.1 | Low3.8 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L |
| NVDNVD · Modified | 3.1 | Low2.7 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.43% · top 62% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.8.
Weakness
Affected products
- affected ≤ 8.7.9
- affected ≤ 8.1.0
- unaffected 7.8.10
- unaffected 8.1.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Gogithub.com/mattermost/mattermost-server/v6GHSA-rp65-jpc7-8h8p (opens in a new tab)
- Gogithub.com/mattermost/mattermost/server/v8GHSA-rp65-jpc7-8h8p (opens in a new tab)
What to do
Solution: Update Mattermost Server to versions 7.8.10, 8.1.1 or higher.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-rp65-jpc7-8h8p (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-5159)Record last updated .