CVE-2023-5502
On affected platforms running Arista EOS with 802.1x authentication configured on the access/trunk ports, a malicious supplicant may bypass authentication.
- Published
- Updated
- Reserved
- Assigned by
- Arista
Description
On affected platforms running Arista EOS with 802.1x authentication configured on the access/trunk ports, and routing enabled on the access VLAN of the ports, a malicious supplicant may be able to bypass the requirement to perform 802.1x authentication.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| AristaCNA (assigner) | 4.0 | High8.2 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N |
| AristaCNA (assigner) | 3.1 | Medium5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N |
| NVDNVD · Awaiting Analysis | 4.0 | High8.2 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.32% · top 75% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.2.
Weakness
Affected products
- affected 4.31.0 – ≤ 4.31.0F
- affected 4.30.0 – ≤ 4.30.4M
- affected 4.29.0 – ≤ 4.29.6M
- affected 4.28.0 – ≤ 4.28.8M
- affected 4.27.0 – ≤ 4.27.11M
- affected 4.26.0 – ≤ 4.26.11M
- affected 4.25.0 – ≤ 4.25.11M
- affected 4.24.0 – ≤ 4.24.11M
What to do
Solution: The recommended resolution is to upgrade to a remediated software version at your earliest convenience. Arista recommends customers move to the latest version of each release that contains all the fixes listed below. For more information about upgrading see EOS User Manual: Upgrades and Downgrades https://www.arista.com/en/um-eos/eos-upgrades-and-downgrades CVE-2023-5502 has been fixed in the following releases: * 4.32.0F and later releases in the 4.32.x train * 4.31.3M and later releases in the 4.31.x train * 4.30.5M and later releases in the 4.30.x train * 4.29.7M and later releases in the 4.29.x train Note: Products 7280E and 7500E are EOL, and there are no released versions of EOS which fix the issue on those platforms.
Workaround: Mitigation of this vulnerability requires disabling dot1x. Dot1x can be disabled globally using the following command: no dot1x system-auth-control
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-5502)Record last updated .