Back
CVE-2023-5995
Incorrect Authorization in GitLab
Medium4.4EPSS 0.56%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An issue has been discovered in GitLab EE affecting all versions starting from 16.2 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for an attacker to abuse the policy bot to gain access to internal projects.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | Medium4.4 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N |
| NVDNVD · Modified | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N |
- EPSS (exploitation in 30 days)
- 0.56% · top 53% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.4.
Weakness
Affected products
What to do
Solution: Upgrade to version 16.4.3, 16.5.3, 16.6.1, or above
References (2)
- GitLab Issue #425361 (opens in a new tab)issue-trackingx_transferred
- HackerOne Bug Bounty Report #2138880 (opens in a new tab)technical-descriptionexploitpermissions-requiredx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-5995)Record last updated .