Back
CVE-2024-0199
Incorrect Authorization in GitLab
High7.7EPSS 0.71%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An authorization bypass vulnerability was discovered in GitLab affecting versions 11.3 prior to 16.7.7, 16.7.6 prior to 16.8.4, and 16.8.3 prior to 16.9.2. An attacker could bypass CODEOWNERS by utilizing a crafted payload in an old feature branch to perform malicious actions.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | High7.7 | CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N |
| NVDNVD · Analyzed | 3.1 | High8.0 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.71% · top 46% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: total
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.7.
Weakness
Affected products
What to do
Solution: Upgrade to versions 16.7.7, 16.8.4, 16.9.2 or above.
References (3)
- GitLab Issue #436977 (opens in a new tab)issue-trackingpermissions-requiredx_transferred
- HackerOne Bug Bounty Report #2295423 (opens in a new tab)technical-descriptionexploitpermissions-requiredx_transferred
- https://about.gitlab.com/releases/2024/03/06/security-release-gitlab-16-9-2-released/ (opens in a new tab)x_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-0199)Record last updated .