CVE-2024-2447
Mattermost versions 8.1.x before 8.1.11, 9.3.x before 9.3.3, 9.4.x before 9.4.4, and 9.5.x before 9.5.2 fail to authenticate the source of…
- Published
- Updated
- Reserved
- Assigned by
- Mattermost
Description
Mattermost versions 8.1.x before 8.1.11, 9.3.x before 9.3.3, 9.4.x before 9.4.4, and 9.5.x before 9.5.2 fail to authenticate the source of certain types of post actions, allowing an authenticated attacker to create posts as other users via a crafted post action.
Timeline
ID reserved
By Mattermost
- 22 days later
· 22 days later
Published
- 4 months later
· 4 months later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| MattermostCNA (assigner) | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N |
| NVDNVD · Analyzed | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N |
- EPSS (exploitation in 30 days)
- 0.22% · top 87% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.5.
Weakness
Affected products
- affected 9.5.0 – ≤ 9.5.1
- affected 9.4.0 – ≤ 9.4.3
- affected 9.3.0 – ≤ 9.3.2
- affected 8.1.0 – ≤ 8.1.10
- unaffected 9.6.0
- unaffected 9.5.2
- unaffected 9.4.4
- unaffected 9.3.3
- unaffected 8.1.11
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Gogithub.com/mattermost/mattermost/server/v8GHSA-wp43-vprh-c3w5 (opens in a new tab)
What to do
Solution: Update Mattermost Server to versions 9.6.0, 9.5.2, 9.4.4, 9.3.3, 8.1.11 or higher.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-wp43-vprh-c3w5 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-2447)Record last updated .