Skip to content
TrackCVE
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-2450

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to correctly verify account…

High8.8EPSS 0.60%
Published
Updated
Reserved
Assigned by
Mattermost

Description

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to correctly verify account ownership when switching from email to SAML authentication, allowing an authenticated attacker to take over other user accounts via a crafted switch request under specific conditions.

Timeline

  1. ID reserved

    By Mattermost

  2. · 1 day later

    Published

  3. · 5 months later

    Record updated

Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.

Scores

CVSS scores of CVE-2024-2450, by who scored it
Scored byCVSSScoreVector
MattermostCNA (assigner)3.1High8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVDNVD · Analyzed3.1High8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.60% · top 51% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.8.

Weakness

Affected products

  • Mattermost · Mattermost

    • affected 9.5.0
    • affected 9.4.0 – ≤ 9.4.2
    • affected 9.3.0 – ≤ 9.3.1
    • affected 9.2.0 – ≤ 9.2.5
    • affected 8.1.0 – ≤ 8.1.9
    • unaffected 9.6.0
    • unaffected 9.4.3
    • unaffected 9.5.1
    • unaffected 9.3.2
    • unaffected 9.2.6
    • unaffected 8.1.10

What to do

Solution: Update Mattermost Server to versions 9.6, 9.4.3, 9.5.1, 9.3.2, 9.2.6, 8.1.10 or higher.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-2450 badge
[![CVE-2024-2450](https://trackcve.app/badge/CVE-2024-2450.svg)](https://trackcve.app/cve/CVE-2024-2450)

Record last updated .