CVE-2024-26008
An improper check or handling of exceptional conditions vulnerability [CWE-703] in FortiOS version 7.4.0 through 7.4.3 and before 7.2.7,…
- Published
- Updated
- Reserved
- Assigned by
- fortinet
Description
An improper check or handling of exceptional conditions vulnerability [CWE-703] in FortiOS version 7.4.0 through 7.4.3 and before 7.2.7, FortiProxy version 7.4.0 through 7.4.3 and before 7.2.9, FortiPAM before 1.2.0 and FortiSwitchManager version 7.2.0 through 7.2.3 and version 7.0.0 through 7.0.3 fgfm daemon may allow an unauthenticated attacker to repeatedly reset the fgfm connection via crafted SSL encrypted TCP requests.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| fortinetCNA (assigner) | 3.1 | Medium5.0 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:X/RC:C |
| NVDNVD · Analyzed | 3.1 | Medium5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L |
- EPSS (exploitation in 30 days)
- 0.58% · top 52% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: yes · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.0.
Weakness
Affected products
- affected 7.4.0 – ≤ 7.4.3
- affected 7.2.0 – ≤ 7.2.9
- affected 7.0.0 – ≤ 7.0.22
- affected 2.0.0 – ≤ 2.0.14
- affected 1.2.0 – ≤ 1.2.13
- affected 1.2.0
- affected 1.1.0 – ≤ 1.1.2
- affected 1.0.0 – ≤ 1.0.3
- affected 7.4.0 – ≤ 7.4.3
- affected 7.2.0 – ≤ 7.2.7
- affected 7.0.0 – ≤ 7.0.18
- affected 6.4.0 – ≤ 6.4.16
- affected 6.2.0 – ≤ 6.2.17
- affected 7.2.0 – ≤ 7.2.3
- affected 7.0.0 – ≤ 7.0.3
What to do
Solution: Upgrade to FortiProxy version 7.4.4 or above Upgrade to FortiProxy version 7.2.10 or above Upgrade to FortiPAM version 1.4.0 or above Upgrade to FortiPAM version 1.3.0 or above Upgrade to FortiOS version 7.6.0 or above Upgrade to FortiOS version 7.4.4 or above Upgrade to FortiOS version 7.2.8 or above Upgrade to FortiSwitchManager version 7.2.4 or above Upgrade to FortiSwitchManager version 7.0.4 or above
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-26008)Record last updated .