Back
CVE-2024-2880
Improper Access Control in GitLab
Low2.7EPSS 0.35%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.5 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2 in which a user with `admin_group_member` custom role permission could ban group members.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | Low2.7 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N |
| NVDNVD · Modified | 3.1 | Low2.7 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.35% · top 71% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 2.7.
Weakness
Affected products
What to do
Solution: Upgrade to versions 16.11.6, 17.0.4, 17.1.2 or above.
References (2)
- GitLab Issue #451921 (opens in a new tab)issue-trackingpermissions-requiredx_transferred
- HackerOne Bug Bounty Report #2431597 (opens in a new tab)technical-descriptionexploitpermissions-requiredx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-2880)Record last updated .