Back
CVE-2024-29004
SolarWinds Platform Stored XSS Vulnerability
High7.1EPSS 0.32%
- Published
- Updated
- Reserved
- Assigned by
- SolarWinds
Description
The SolarWinds Platform was determined to be affected by a stored cross-site scripting vulnerability affecting the web console. A high-privileged user and user interaction is required to exploit this vulnerability.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| SolarWindsCNA (assigner) | 3.1 | High7.1 | CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L |
| NVDNVD · Analyzed | 3.1 | Medium4.3 | CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.32% · top 75% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.1.
Weakness
Affected products
SolarWinds · SolarWinds Platform
- affected 2024.1.1 and previous versions
What to do
Solution: SolarWinds recommends that customers upgrade to SolarWinds Platform 2024.2 as soon as it becomes available.
References (2)
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2024-29004 (opens in a new tab)vendor-advisoryx_transferred
- https://documentation.solarwinds.com/en/success_center/orionplatform/content/release_notes/solarwinds_platform_2024-2_release_notes.htm (opens in a new tab)release-notesx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-29004)Record last updated .