CVE-2024-32111
WordPress core < 6.5.5 - Auth. Arbitrary .html File Read (Windows Only) vulnerability
- Published
- Updated
- Reserved
- Assigned by
- Patchstack
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Automattic WordPress allows Relative Path Traversal.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9, from 5.8 through 5.8.9, from 5.7 through 5.7.11, from 5.6 through 5.6.13, from 5.5 through 5.5.14, from 5.4 through 5.4.15, from 5.3 through 5.3.17, from 5.2 through 5.2.20, from 5.1 through 5.1.18, from 5.0 through 5.0.21, from 4.9 through 4.9.25, from 4.8 through 4.8.24, from 4.7 through 4.7.28, from 4.6 through 4.6.28, from 4.5 through 4.5.31, from 4.4 through 4.4.32, from 4.3 through 4.3.33, from 4.2 through 4.2.37, from 4.1 through 4.1.40.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| PatchstackCNA (assigner) | 3.1 | Medium5.0 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L |
| NVDNVD · Deferred | 3.1 | Medium5.0 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L |
- EPSS (exploitation in 30 days)
- 0.48% · top 59% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.0.
Weakness
Affected products
- affected 6.5 – ≤ 6.5.4
- affected 6.4 – ≤ 6.4.4
- affected 6.3 – ≤ 6.3.4
- affected 6.2 – ≤ 6.2.5
- affected 6.1 – ≤ 6.1.6
- affected 6.0 – ≤ 6.0.8
- affected 5.9 – ≤ 5.9.9
- affected 5.8 – ≤ 5.8.9
- affected 5.7 – ≤ 5.7.11
- affected 5.6 – ≤ 5.6.13
- affected 5.5 – ≤ 5.5.14
- affected 5.4 – ≤ 5.4.15
- affected 5.3 – ≤ 5.3.17
- affected 5.2 – ≤ 5.2.20
- affected 5.1 – ≤ 5.1.18
- affected 5.0 – ≤ 5.0.21
- affected 4.9 – ≤ 4.9.25
- affected 4.8 – ≤ 4.8.24
- affected 4.7 – ≤ 4.7.28
- affected 4.6 – ≤ 4.6.28
- affected 4.5 – ≤ 4.5.31
- affected 4.4 – ≤ 4.4.32
- affected 4.3 – ≤ 4.3.33
- affected 4.2 – ≤ 4.2.37
- affected 4.1 – ≤ 4.1.40
What to do
Solution: Update to safe (6.5.5, 6.4.5, 6.3.5, 6.2.6, 6.1.7, 6.0.9, 5.9.10, 5.8.10, 5.7.12, 5.6.14, 5.5.15, 5.4.16, 5.3.18, 5.2.21, 5.1.19, 5.0.22, 4.9.26, 4.8.25, 4.7.29, 4.6.29, 4.5.32, 4.4.33, 4.3.34, 4.2.38, 4.1.41) or higher version.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-32111)Record last updated .