Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-32465

Git's protections for cloning untrusted repositories can be bypassed

High7.4EPSS 1.0%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

Git is a revision control system. The Git project recommends to avoid working in untrusted repositories, and instead to clone it first with `git clone --no-local` to obtain a clean copy. Git has specific protections to make that a safe operation even with an untrusted source repository, but vulnerabilities allow those protections to be bypassed. In the context of cloning local repositories owned by other users, this vulnerability has been covered in CVE-2024-32004. But there are circumstances where the fixes for CVE-2024-32004 are not enough: For example, when obtaining a `.zip` file containing a full copy of a Git repository, it should not be trusted by default to be safe, as e.g. hooks could be configured to run within the context of that repository. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid using Git in repositories that have been obtained via archives from untrusted sources.

Scores

CVSS scores of CVE-2024-32465, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1High7.4CVSS:3.1/AV:P/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
NVDNVD · Analyzed3.1High7.8CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
1.0% · top 36% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.4.

Weakness

Affected products

  • git · git

    • affected = 2.45.0
    • affected = 2.44.0
    • affected >= 2.43.0, < 2.43.4
    • affected >= 2.42.0, < 2.42.2
    • affected = 2.41.0
    • affected >= 2.40.0, < 2.40.2
    • affected < 2.39.4

References (8)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-32465 badge
[![CVE-2024-32465](https://trackcve.app/badge/CVE-2024-32465.svg)](https://trackcve.app/cve/CVE-2024-32465)

Record last updated .