Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-35280

A improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Fortinet FortiDeceptor 5.3.0,…

Medium5.1EPSS 0.29%
Published
Updated
Reserved
Assigned by
fortinet

Description

A improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Fortinet FortiDeceptor 5.3.0, FortiDeceptor 5.2.0, FortiDeceptor 5.1 all versions, FortiDeceptor 5.0 all versions, FortiDeceptor 4.3 all versions, FortiDeceptor 4.2 all versions, FortiDeceptor 4.1 all versions, FortiDeceptor 4.0 all versions, FortiDeceptor 3.3 all versions, FortiDeceptor 3.2 all versions, FortiDeceptor 3.1 all versions, FortiDeceptor 3.0 all versions may allow an attacker to perform a reflected cross-site scripting attack in the recovery endpoints

Timeline

  1. ID reserved

    By fortinet

  2. · 8 months later

    Published

  3. · 13 months later

    Record updated

Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.

Scores

CVSS scores of CVE-2024-35280, by who scored it
Scored byCVSSScoreVector
fortinetCNA (assigner)3.1Medium5.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:U/RC:C
NVDNVD · Modified3.1Medium6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS (exploitation in 30 days)
0.29% · top 78% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.1.

Weakness

Affected products

  • Fortinet · FortiDeceptor

    • affected 5.3.0
    • affected 5.2.0
    • affected 5.1.0
    • affected 5.0.0
    • affected 4.3.0
    • affected 4.2.0
    • affected 4.1.0 – ≤ 4.1.1
    • affected 4.0.0 – ≤ 4.0.2
    • affected 3.3.0 – ≤ 3.3.3
    • affected 3.2.0 – ≤ 3.2.2
    • affected 3.1.0 – ≤ 3.1.1
    • affected 3.0.0 – ≤ 3.0.2

What to do

Solution: Upgrade to FortiDeceptor version 6.0.0 or above Upgrade to FortiDeceptor version 5.3.1 or above Upgrade to FortiDeceptor version 5.2.1 or above

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-35280 badge
[![CVE-2024-35280](https://trackcve.app/badge/CVE-2024-35280.svg)](https://trackcve.app/cve/CVE-2024-35280)

Record last updated .