Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-37307

Cilium leaks sensitive information in cilium-bugtool

High7.9EPSS 0.18%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.0 and prior to versions 1.13.7, 1.14.12, and 1.15.6, the output of `cilium-bugtool` can contain sensitive data when the tool is run (with the `--envoy-dump` flag set) against Cilium deployments with the Envoy proxy enabled. Users of the TLS inspection, Ingress with TLS termination, Gateway API with TLS termination, and Kafka network policies with API key filtering features are affected. The sensitive data includes the CA certificate, certificate chain, and private key used by Cilium HTTP Network Policies, and when using Ingress/Gateway API and the API keys used in Kafka-related network policy. `cilium-bugtool` is a debugging tool that is typically invoked manually and does not run during the normal operation of a Cilium cluster. This issue has been patched in Cilium v1.15.6, v1.14.12, and v1.13.17. There is no workaround to this issue.

Scores

CVSS scores of CVE-2024-37307, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1High7.9CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
NVDNVD · Analyzed3.1Medium6.5CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS (exploitation in 30 days)
0.18% · top 92% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.9.

Weakness

Affected products

  • cilium · cilium

    • affected >= 1.13.0, < 1.13.17
    • affected >= 1.14.0, < 1.14.12
    • affected >= 1.15.0, < 1.15.6

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (7)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-37307 badge
[![CVE-2024-37307](https://trackcve.app/badge/CVE-2024-37307.svg)](https://trackcve.app/cve/CVE-2024-37307)

Record last updated .