Back
CVE-2024-4099
Improper Encoding or Escaping of Output in GitLab
Low3.1EPSS 0.29%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An issue has been discovered in GitLab EE affecting all versions starting from 16.0 prior to 17.2.8, from 17.3 prior to 17.3.4, and from 17.4 prior to 17.4.1. An AI feature was found to read unsanitized content in a way that could have allowed an attacker to hide prompt injection.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | Low3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N |
| NVDNVD · Analyzed | 3.1 | Medium5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.29% · top 78% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.1.
Weakness
Affected products
What to do
Solution: Upgrade to versions 17.2.8, 17.3.4, 17.4.1 or above.
References (2)
- GitLab Issue #457798 (opens in a new tab)issue-trackingpermissions-required
- HackerOne Bug Bounty Report #2459597 (opens in a new tab)technical-descriptionexploitpermissions-required
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2024-4099)Record last updated .