Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-56145

RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms

Critical9.3Known exploitedEPSS 97.5%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Exploited in the wild

CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Craft CMS Code Injection Vulnerability.

Added
2 Jun 2025
Fix due (US federal)
23 Jun 2025
Used by ransomware
Not known

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Scores

CVSS scores of CVE-2024-56145, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)4.0Critical9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
NVDNVD · Analyzed4.0Critical9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS (exploitation in 30 days)
97.5% · top 0.1% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: active · Automatable: yes · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.3.

Weakness

Affected products

  • craftcms · cms

    • affected >= 4.0.0-RC1, < 4.13.2
    • affected >= 5.0.0-RC1, < 5.5.2
    • affected >= 3.0.0, < 3.9.14

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (4)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-56145 badge
[![CVE-2024-56145](https://trackcve.app/badge/CVE-2024-56145.svg)](https://trackcve.app/cve/CVE-2024-56145)

Record last updated .