Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-7110

Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

Medium6.4EPSS 0.36%
Published
Updated
Reserved
Assigned by
GitLab

Description

An issue was discovered in GitLab EE affecting all versions starting 17.0 to 17.1.6, 17.2 prior to 17.2.4, and 17.3 prior to 17.3.1 allows an attacker to execute arbitrary command in a victim's pipeline through prompt injection.

Scores

CVSS scores of CVE-2024-7110, by who scored it
Scored byCVSSScoreVector
GitLabCNA (assigner)3.1Medium6.4CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
NVDNVD · Analyzed3.1Medium6.4CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS (exploitation in 30 days)
0.36% · top 70% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.4.

Weakness

Affected products

  • GitLab · GitLab

    • affected 17.1 – < 17.1.6
    • affected 17.2 – < 17.2.4
    • affected 17.3 – < 17.3.1

What to do

Solution: Upgrade to versions 17.3.1, 17.2.4, 17.1.6 or above.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-7110 badge
[![CVE-2024-7110](https://trackcve.app/badge/CVE-2024-7110.svg)](https://trackcve.app/cve/CVE-2024-7110)

Record last updated .