Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-8970

Incorrect Authorization in GitLab

High8.2EPSS 0.68%
Published
Updated
Reserved
Assigned by
GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 11.6 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.

Scores

CVSS scores of CVE-2024-8970, by who scored it
Scored byCVSSScoreVector
GitLabCNA (assigner)3.1High8.2CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
NVDNVD · Analyzed3.1High8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.68% · top 48% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.2.

Weakness

Affected products

  • GitLab · GitLab

    • affected 11.6 – < 17.2.9
    • affected 17.3 – < 17.3.5
    • affected 17.4 – < 17.4.2

What to do

Solution: Upgrade to versions 17.2.9, 17.3.5, 17.4.2 or above.

References (2)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-8970 badge
[![CVE-2024-8970](https://trackcve.app/badge/CVE-2024-8970.svg)](https://trackcve.app/cve/CVE-2024-8970)

Record last updated .