Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2024-9870

Unintended Proxy or Intermediary ('Confused Deputy') in GitLab

Medium4.3EPSS 0.39%
Published
Updated
Reserved
Assigned by
GitLab

Description

An external service interaction vulnerability in GitLab EE affecting all versions from 15.11 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 allows an attacker to send requests from the GitLab server to unintended services.

Scores

CVSS scores of CVE-2024-9870, by who scored it
Scored byCVSSScoreVector
GitLabCNA (assigner)3.1Medium4.3CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
NVDNVD · Analyzed3.1High8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.39% · top 66% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.3.

Weakness

Affected products

  • GitLab · GitLab

    • affected 15.11 – < 17.6.5
    • affected 17.7 – < 17.7.4
    • affected 17.8 – < 17.8.2

What to do

Solution: Upgrade to versions 17.8.2, 17.7.4, 17.6.5 or above.

References (2)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2024-9870 badge
[![CVE-2024-9870](https://trackcve.app/badge/CVE-2024-9870.svg)](https://trackcve.app/cve/CVE-2024-9870)

Record last updated .