CVE-2025-12421
Account Takeover via Code Exchange Endpoint
- Published
- Updated
- Reserved
- Assigned by
- Mattermost
Description
Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).
Timeline
ID reserved
By Mattermost
- 30 days later
· 30 days later
Published
- 3 months later
· 3 months later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| MattermostCNA (assigner) | 3.1 | Critical9.9 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H |
| NVDNVD · Analyzed | 3.1 | Critical9.9 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.45% · top 61% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.9.
Weakness
Affected products
- affected 11.0.0 – ≤ 11.0.2
- affected 10.12.0 – ≤ 10.12.1
- affected 10.11.0 – ≤ 10.11.4
- affected 10.5.0 – ≤ 10.5.12
- unaffected 11.1.0
- unaffected 11.0.3
- unaffected 10.12.2
- unaffected 10.11.5
- unaffected 10.5.13
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Gogithub.com/mattermost/mattermost-serverGHSA-mp6x-97xj-9x62 (opens in a new tab)
- Gogithub.com/mattermost/mattermost/server/v8GHSA-mp6x-97xj-9x62 (opens in a new tab)
What to do
Solution: Update Mattermost to versions 11.1.0, 11.0.3, 10.12.2, 10.11.5, 10.5.13 or higher.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-mp6x-97xj-9x62 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-12421)Record last updated .