CVE-2025-22258
A heap-based buffer overflow in Fortinet FortiSRA 1.5.0, 1.4.0 through 1.4.2, FortiPAM 1.5.0, 1.4.0 through 1.4.2, 1.3.0 through 1.3.1,…
- Published
- Updated
- Reserved
- Assigned by
- fortinet
Description
A heap-based buffer overflow in Fortinet FortiSRA 1.5.0, 1.4.0 through 1.4.2, FortiPAM 1.5.0, 1.4.0 through 1.4.2, 1.3.0 through 1.3.1, 1.2.0, 1.1.0 through 1.1.2, 1.0.0 through 1.0.3, FortiProxy 7.6.0 through 7.6.1, 7.4.0 through 7.4.7, FortiOS 7.6.0 through 7.6.2, 7.4.0 through 7.4.6, 7.2.0 through 7.2.10, 7.0.2 through 7.0.16, FortiSwitchManager 7.2.1 through 7.2.5 allows attackers to escalate their privilege via specially crafted http requests.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| fortinetCNA (assigner) | 3.1 | Medium5.7 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H/E:P/RL:W/RC:R |
| NVDNVD · Analyzed | 3.1 | High7.2 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.56% · top 53% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.7.
Weakness
Affected products
- affected 1.5.0
- affected 1.4.0 – ≤ 1.4.2
- affected 1.3.0 – ≤ 1.3.1
- affected 1.2.0
- affected 1.1.0 – ≤ 1.1.2
- affected 1.0.0 – ≤ 1.0.3
- affected 7.6.0 – ≤ 7.6.2
- affected 7.4.0 – ≤ 7.4.6
- affected 7.2.0 – ≤ 7.2.10
- affected 7.0.2 – ≤ 7.0.16
- affected 1.5.0
- affected 1.4.0 – ≤ 1.4.2
- affected 7.6.0 – ≤ 7.6.1
- affected 7.4.0 – ≤ 7.4.7
- affected 7.2.1 – ≤ 7.2.5
What to do
Solution: Upgrade to FortiPAM version 1.6.0 or above Upgrade to FortiPAM version 1.5.1 or above Upgrade to FortiPAM version 1.4.3 or above Fortinet remediated this issue in FortiSASE version 25.1.b and hence customers do not need to perform any action. Upgrade to FortiOS version 7.6.3 or above Upgrade to FortiOS version 7.4.7 or above Upgrade to FortiOS version 7.2.11 or above Upgrade to FortiOS version 7.0.17 or above Upgrade to FortiSRA version 1.6.0 or above Upgrade to FortiSRA version 1.5.1 or above Upgrade to FortiSRA version 1.4.3 or above Upgrade to FortiProxy version 7.6.2 or above Upgrade to FortiProxy version 7.4.8 or above Upgrade to FortiSwitchManager version 7.2.6 or above
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-22258)Record last updated .