Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2025-24813

Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

Critical10.0Known exploitedEPSS 99.9%
Published
Updated
Reserved
Assigned by
apache

Description

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Exploited in the wild

CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Apache Tomcat Path Equivalence Vulnerability.

Added
1 Apr 2025
Fix due (US federal)
22 Apr 2025
Used by ransomware
Not known

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Scores

CVSS scores of CVE-2025-24813, by who scored it
Scored byCVSSScoreVector
CISA-ADPADP (enrichment)3.1Critical10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
NVDNVD · Analyzed3.1Critical9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
99.9% · top 0.1% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: active · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 10.0.

Weakness

Affected products

  • Apache Software Foundation · Apache Tomcat

    • affected 11.0.0-M1 – ≤ 11.0.2
    • affected 10.1.0-M1 – ≤ 10.1.34
    • affected 9.0.0.M1 – ≤ 9.0.98
    • affected 8.5.0 – ≤ 8.5.100
    • unknown 3 – < 8.5.0
    • unknown 10.0.0-M1 – ≤ 10.0.27

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (10)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2025-24813 badge
[![CVE-2025-24813](https://trackcve.app/badge/CVE-2025-24813.svg)](https://trackcve.app/cve/CVE-2025-24813)

Record last updated .