CVE-2025-40907
FCGI versions 0.44 through 0.82, for Perl, include a vulnerable version of the FastCGI fcgi2 (aka fcgi) library
- Published
- Updated
- Reserved
- Assigned by
- CPANSec
Description
FCGI versions 0.44 through 0.82, for Perl, include a vulnerable version of the FastCGI fcgi2 (aka fcgi) library. The included FastCGI library is affected by CVE-2025-23016, causing an integer overflow (and resultant heap-based buffer overflow) via crafted nameLen or valueLen values in data to the IPC socket. This occurs in ReadParams in fcgiapp.c.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | Medium5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L |
| NVDNVD · Analyzed | 3.1 | Medium5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L |
- EPSS (exploitation in 30 days)
- 0.68% · top 48% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.3.
Weakness
Affected products
What to do
Workaround: Updating to version 2.4.5 of the included fcgi2 library and rebuilding the Perl module will protect against the vulnerability. We also recommend limiting potential remote access to the FastCGI socket by declaring it as a UNIX socket.
Exploitation: A proof of concept exploit for the underlying library exists at https://www.synacktiv.com/en/publications/cve-2025-23016-exploiting-the-fastcgi-library#exploitation
References (6)
- http://www.openwall.com/lists/oss-security/2025/04/23/4 (opens in a new tab)mailing-list
- https://github.com/FastCGI-Archives/fcgi2/issues/67 (opens in a new tab)issue-tracking
- https://github.com/FastCGI-Archives/fcgi2/releases/tag/2.4.5 (opens in a new tab)patch
- https://www.synacktiv.com/en/publications/cve-2025-23016-exploiting-the-fastcgi-library (opens in a new tab)technical-description
- https://github.com/perl-catalyst/FCGI/issues/14 (opens in a new tab)issue-tracking
- https://patch-diff.githubusercontent.com/raw/FastCGI-Archives/fcgi2/pull/74.patch (opens in a new tab)patch
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-40907)Record last updated .