CVE-2025-49581
XWiki allows remote code execution through default value of wiki macro wiki-type parameters
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
XWiki is a generic wiki platform. Any user with edit right on a page (could be the user's profile) can execute code (Groovy, Python, Velocity) with programming right by defining a wiki macro. This allows full access to the whole XWiki installation. The main problem is that if a wiki macro parameter allows wiki syntax, its default value is executed with the rights of the author of the document where it is used. This can be exploited by overriding a macro like the children macro that is used in a page that has programming right like the page XWiki.ChildrenMacro and thus allows arbitrary script macros. This vulnerability has been patched in XWiki 16.4.7, 16.10.3 and 17.0.0 by executing wiki parameters with the rights of the wiki macro's author when the parameter's value is the default value.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 4.0 | High8.7 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N |
| NVDNVD · Analyzed | 4.0 | High8.7 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.59% · top 52% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.7.
Weakness
- CWE-94: Improper Control of Generation of Code ('Code Injection') (opens in a new tab)All about CWE-94 and its CVEs
- CWE-270: Privilege Context Switching Error (opens in a new tab)All about CWE-270 and its CVEs
- CWE-250: Execution with Unnecessary Privileges (opens in a new tab)All about CWE-250 and its CVEs
Affected products
- affected >= 11.10.11, < 12.0
- affected >= 12.6.3, < 12.7
- affected >= 12.8-rc-1, < 16.4.7
- affected >= 16.5.0-rc-1, < 16.10.3
- affected >= 17.0.0-rc-1, < 17.0.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.xwiki.platform:xwiki-platform-rendering-wikimacro-storeGHSA-9875-cw22-f7cx (opens in a new tab)
References (3)
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9875-cw22-f7cx (opens in a new tab)x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/c99d501ed41cbee6a3c02ff927714531570789de (opens in a new tab)x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-22760 (opens in a new tab)x_refsource_MISC
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-9875-cw22-f7cx (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-49581)Record last updated .