Back
CVE-2025-4976
Exposure of Sensitive Information Due to Incompatible Policies in GitLab
Medium4.3EPSS 0.50%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An issue has been discovered in GitLab EE affecting all versions from 17.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that, under certain circumstances, could have allowed an attacker to access internal notes in GitLab Duo responses.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | Medium4.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N |
| NVDNVD · Analyzed | 3.1 | Medium5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N |
- EPSS (exploitation in 30 days)
- 0.50% · top 57% of all CVEs (5 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.3.
Weakness
Affected products
What to do
Solution: Upgrade to versions 18.0.5, 18.1.3, 18.2.1 or above.
References (2)
- GitLab Issue #543905 (opens in a new tab)issue-trackingpermissions-required
- HackerOne Bug Bounty Report #3149956 (opens in a new tab)technical-descriptionexploitpermissions-required
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-4976)Record last updated .