Back
CVE-2025-5302
Denial of Service (DOS) in JSONReader in run-llama/llama_index
High8.6EPSS 0.29%
- Published
- Updated
- Reserved
- Assigned by
- @huntr_ai
Description
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| @huntr_aiCNA (assigner) | 3.0 | High8.6 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H |
| NVDNVD · Deferred | 3.0 | High8.6 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H |
- EPSS (exploitation in 30 days)
- 0.29% · top 79% of all CVEs (5 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.6.
Weakness
Affected products
run-llama · run-llama/llama_index
- affected unspecified – < 0.12.38
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- PyPIllama-index-coreGHSA-7753-xrfw-ch36 (opens in a new tab)
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-7753-xrfw-ch36 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-5302)Record last updated .