Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2025-58437

Coder's privilege escalation vulnerability could lead to a cross workspace compromise

High8.1EPSS 0.41%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

Coder allows organizations to provision remote development environments via Terraform. In versions 2.22.0 through 2.24.3, 2.25.0 and 2.25.1, Coder can be compromised through insecure session handling in prebuilt workspaces. Coder automatically generates a session token for a user when a workspace is started. It is automatically exposed via coder_workspace_owner.session_token. Prebuilt workspaces are initially owned by a built-in prebuilds system user. When a prebuilt workspace is claimed, a new session token is generated for the user that claimed the workspace, but the previous session token for the prebuilds user was not expired. Any Coder workspace templates that persist this automatically generated session token are potentially impacted. This is fixed in versions 2.24.4 and 2.25.2.

Scores

CVSS scores of CVE-2025-58437, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1High8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
NVDNVD · Analyzed3.1High8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS (exploitation in 30 days)
0.41% · top 64% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.1.

Weakness

Affected products

  • coder · coder

    • affected >= 2.22.0, < 2.24.4
    • affected >= 2.25.0, < 2.25.2

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (7)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2025-58437 badge
[![CVE-2025-58437](https://trackcve.app/badge/CVE-2025-58437.svg)](https://trackcve.app/cve/CVE-2025-58437)

Record last updated .