CVE-2025-58674
WordPress <= 6.8.2 - (Author+) Cross Site Scripting (XSS) Vulnerability
- Published
- Updated
- Reserved
- Assigned by
- Patchstack
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPress allows Stored XSS. WordPress core security team is aware of the issue and working on a fix. This is low severity vulnerability that requires an attacker to have Author or higher user privileges to execute the attack vector.This issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| PatchstackCNA (assigner) | 3.1 | Medium5.9 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L |
| NVDNVD · Deferred | 3.1 | Medium5.9 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L |
- EPSS (exploitation in 30 days)
- 0.22% · top 88% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.9.
Weakness
Affected products
- affected 6.8 – ≤ 6.8.2
- affected 6.7 – ≤ 6.7.3
- affected 6.6 – ≤ 6.6.3
- affected 6.5 – ≤ 6.5.6
- affected 6.4 – ≤ 6.4.6
- affected 6.3 – ≤ 6.3.6
- affected 6.2 – ≤ 6.2.7
- affected 6.1 – ≤ 6.1.8
- affected 6.0 – ≤ 6.0.10
- affected 5.9 – ≤ 5.9.11
- affected 5.8 – ≤ 5.8.11
- affected 5.7 – ≤ 5.7.13
- affected 5.6 – ≤ 5.6.15
- affected 5.5 – ≤ 5.5.16
- affected 5.4 – ≤ 5.4.17
- affected 5.3 – ≤ 5.3.19
- affected 5.2 – ≤ 5.2.22
- affected 5.1 – ≤ 5.1.20
- affected 5.0 – ≤ 5.0.23
- affected 4.9 – ≤ 4.9.27
- affected 4.8 – ≤ 4.8.26
- affected 4.7 – ≤ 4.7.30
What to do
Solution: Update WordPress to one of the following patched or higher versions: 6.8.3, 6.7.4, 6.6.4, 6.5.7, 6.4.7, 6.3.7, 6.2.8, 6.1.9, 6.0.11, 5.9.12, 5.8.12, 5.7.14, 5.6.16, 5.5.17, 5.4.18, 5.3.20, 5.2.23, 5.1.21, 5.0.24, 4.9.28, 4.8.27, or 4.7.31.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-58674)Record last updated .