CVE-2025-5889
juliangruber brace-expansion index.js expand redos
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 4.0 | Low2.3 | CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P |
| VulDBCNA (assigner) | 3.1 | Low3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C |
| VulDBCNA (assigner) | 3.0 | Low3.1 | CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C |
| VulDBCNA (assigner) | 2.0 | Low2.1 | AV:N/AC:H/Au:S/C:N/I:N/A:P/E:POC/RL:OF/RC:C |
| NVDNVD · Deferred | 4.0 | Low1.3 | CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.61% · top 51% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 2.3.
Weakness
Affected products
juliangruber · brace-expansion
- affected 1.1.0
- affected 1.1.1
- affected 1.1.2
- affected 1.1.3
- affected 1.1.4
- affected 1.1.5
- affected 1.1.6
- affected 1.1.7
- affected 1.1.8
- affected 1.1.9
- affected 1.1.10
- affected 1.1.11
- affected 2.0.0
- affected 2.0.1
- affected 3.0
- affected 4.0
- unaffected 1.1.12
- unaffected 2.0.2
- unaffected 3.0.1
- unaffected 4.0.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- npmbrace-expansionGHSA-v6h2-p8h4-qcjw (opens in a new tab)
References (6)
- VDB-311660 | juliangruber brace-expansion index.js expand redos (opens in a new tab)vdb-entrytechnical-description
- VDB-311660 | CTI Indicators (IOB, IOC, TTP, IOA) (opens in a new tab)signaturepermissions-required
- Submit #585717 | juliangruber @juliangruber/brace-expansion 1.1.11 Inefficient Regular Expression Complexity (opens in a new tab)third-party-advisory
- https://gist.github.com/mmmsssttt404/37a40ce7d6e5ca604858fe30814d9466 (opens in a new tab)exploit
- https://github.com/juliangruber/brace-expansion/pull/65/commits/a5b98a4f30d7813266b221435e1eaaf25a1b0ac5 (opens in a new tab)issue-trackingpatch
- https://github.com/juliangruber/brace-expansion/releases/tag/v4.0.1 (opens in a new tab)patch
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-v6h2-p8h4-qcjw (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-5889)Record last updated .