Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2025-59472

A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR…

Medium5.9EPSS 0.43%
Published
Updated
Reserved
Assigned by
hackerone

Description

A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR resume endpoint accepts unauthenticated POST requests with the `Next-Resume: 1` header and processes attacker-controlled postponed state data. Two closely related vulnerabilities allow an attacker to crash the server process through memory exhaustion: 1. **Unbounded request body buffering**: The server buffers the entire POST request body into memory using `Buffer.concat()` without enforcing any size limit, allowing arbitrarily large payloads to exhaust available memory. 2. **Unbounded decompression (zipbomb)**: The resume data cache is decompressed using `inflateSync()` without limiting the decompressed output size. A small compressed payload can expand to hundreds of megabytes or gigabytes, causing memory exhaustion. Both attack vectors result in a fatal V8 out-of-memory error (`FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory`) causing the Node.js process to terminate. The zipbomb variant is particularly dangerous as it can bypass reverse proxy request size limits while still causing large memory allocation on the server. To be affected you must have an application running with `experimental.ppr: true` or `cacheComponents: true` configured along with the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable. Strongly consider upgrading to 15.6.0-canary.61 or 16.1.5 to reduce risk and prevent availability issues in Next applications.

Scores

CVSS scores of CVE-2025-59472, by who scored it
Scored byCVSSScoreVector
hackeroneCNA (assigner)3.1Medium5.9CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
NVDNVD · Analyzed3.1High7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS (exploitation in 30 days)
0.43% · top 63% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.9.

Weakness

Affected products

  • vercel · next

    • affected 15.0.0-canary.0 – < 15.0.0
    • affected 15.0.1-canary.0 – < 15.0.1
    • affected 15.0.2-canary.0 – < 15.0.2
    • affected 15.0.3-canary.0 – < 15.0.3
    • affected 15.0.4-canary.0 – < 15.0.4
    • affected 15.1.0-canary.0 – < 15.1.0
    • affected 15.1.1-canary.0 – < 15.1.1
    • affected 15.1.2-canary.0 – < 15.1.2
    • affected 15.1.3-canary.0 – < 15.1.3
    • affected 15.1.4-canary.0 – < 15.1.4
    • affected 15.1.5-canary.0 – < 15.1.5
    • affected 15.1.6-canary.0 – < 15.1.6
    • affected 15.1.7-canary.0 – < 15.1.7
    • affected 15.2.0-canary.0 – < 15.2.0
    • affected 15.2.1-canary.0 – < 15.2.1
    • affected 15.2.2-canary.0 – < 15.2.2
    • affected 15.2.3-canary.0 – < 15.2.3
    • affected 15.2.4-canary.0 – < 15.2.4
    • affected 15.2.5-canary.0 – < 15.2.5
    • affected 15.3.0-canary.0 – < 15.3.0
    • affected 15.3.1-canary.0 – < 15.3.1
    • affected 15.3.2-canary.0 – < 15.3.2
    • affected 15.1.8-canary.0 – < 15.1.8
    • affected 15.3.3-canary.0 – < 15.3.3
    • affected 15.4.0-canary.0 – < 15.4.0
    • affected 15.3.4-canary.0 – < 15.3.4
    • affected 15.3.5-canary.0 – < 15.3.5
    • affected 15.4.1-canary.0 – < 15.4.1
    • affected 15.4.2-canary.0 – < 15.4.2
    • affected 15.4.3-canary.0 – < 15.4.3
    • affected 15.4.4-canary.0 – < 15.4.4
    • affected 15.4.5-canary.0 – < 15.4.5
    • affected 15.4.6-canary.0 – < 15.4.6
    • affected 15.4.7-canary.0 – < 15.4.7
    • affected 15.5.0-canary.0 – < 15.5.0
    • affected 15.5.1-canary.0 – < 15.5.1
    • affected 15.5.2-canary.0 – < 15.5.2
    • affected 15.5.3-canary.0 – < 15.5.3
    • affected 15.5.4-canary.0 – < 15.5.4
    • affected 15.5.5-canary.0 – < 15.5.5
    • and 20 more

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2025-59472 badge
[![CVE-2025-59472](https://trackcve.app/badge/CVE-2025-59472.svg)](https://trackcve.app/cve/CVE-2025-59472)

Record last updated .