CVE-2025-65944
Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 4.0 | Medium5.1 | CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L |
| NVDNVD · Deferred | 4.0 | Medium5.1 | CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.37% · top 69% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.1.
Weakness
Affected products
- affected >= 10.11.0, < 10.27.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- npm@sentry/astroGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/aws-serverlessGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/bunGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/google-cloud-serverlessGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/nestjsGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/nextjsGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/nodeGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/node-coreGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/nuxtGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/remixGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/solidstartGHSA-6465-jgvq-jhgp (opens in a new tab)
- npm@sentry/sveltekitGHSA-6465-jgvq-jhgp (opens in a new tab)
References (4)
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-6465-jgvq-jhgp (opens in a new tab)x_refsource_CONFIRM
- https://github.com/getsentry/sentry-javascript/pull/17475 (opens in a new tab)x_refsource_MISC
- https://github.com/getsentry/sentry-javascript/commit/a820fa2891fdcf985b834a5b557edf351ec54539 (opens in a new tab)x_refsource_MISC
- https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0 (opens in a new tab)x_refsource_MISC
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-6465-jgvq-jhgp (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-65944)Record last updated .