Back
CVE-2025-9353
Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
Medium6.4EPSS 0.33%
- Published
- Updated
- Reserved
- Assigned by
- Wordfence
Description
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| WordfenceCNA (assigner) | 3.1 | Medium6.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N |
| NVDNVD · Deferred | 3.1 | Medium6.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.33% · top 73% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.4.
Weakness
Affected products
- affected ≤ 7.6.9
References (7)
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95 (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73 (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96 (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js (opens in a new tab)
- https://plugins.trac.wordpress.org/changeset/3366817/ (opens in a new tab)
- https://plugins.trac.wordpress.org/changeset/3355757/ (opens in a new tab)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2025-9353)Record last updated .