CVE-2026-0322
PAN-OS: Authenticated Remote Code Execution (RCE) in the Management Interface
- Published
- Updated
- Reserved
- Assigned by
- palo_alto
Description
A remote code execution (RCE) vulnerability in the management interface of Palo Alto Networks PAN-OS® software enables an authenticated attacker with network access to execute arbitrary code with root privileges on the firewall. The security risk posed by this issue is minimized by restricting access to the management interface to only trusted internal IP addresses according to our recommended best practice deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not impacted by this vulnerability.
Exploited in the wild
CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Palo Alto Networks PAN-OS Code Injection Vulnerability.
- Added
- 14 Oct 2026
- Fix due (US federal)
- 17 Oct 2026
- Used by ransomware
- Not known
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| palo_altoCNA (assigner) | 4.0 | High8.6 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A/AU:N/R:U/V:D/RE:M/U:Red |
| palo_altoCNA (assigner) | 4.0 | High8.5 | CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A/AU:N/R:U/V:D/RE:M/U:Red |
| NVDNVD · Analyzed | 4.0 | High8.6 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:N/R:U/V:D/RE:M/U:Red |
- EPSS (exploitation in 30 days)
- 1.7% · top 22% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: active · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.6.
Weakness
Affected products
Palo Alto Networks · Cloud NGFW
- unaffected All
- affected 12.2.0 – < 12.2.4
- affected 12.1.0 – < 12.1.10-h2
- affected 11.2.0 – < 11.2.16
- affected 11.1.0 – < 11.1.16-h3
- affected 10.2.0 – < 10.2.18-h12
Palo Alto Networks · Prisma Access
- unaffected All
What to do
Solution: Version Minor Version Suggested Solution PAN-OS 12.2 12.2.0 through 12.2.3 Upgrade to 12.2.4 or later. PAN-OS 12.1 12.1.8 through 12.1.10-h* Upgrade to 12.1.10-h2 or later. 12.1.5 through 12.1.7-h* Upgrade to 12.1.7-h8 or 12.1.10-h2 or later. 12.1.2 through 12.1.4-h* Upgrade to 12.1.4-h12 or 12.1.10-h2 or later. PAN-OS 11.2 11.2.14 through 11.2.15 Upgrade to 11.2.16 or later. 11.2.11 through 11.2.13-h* Upgrade to 11.2.13-h3 or 11.2.16 or later. 11.2.8 through 11.2.10-h* Upgrade to 11.2.10-h15 or 11.2.16 or later. 11.2.5 through 11.2.7-h* Upgrade to 11.2.7-h21 or 11.2.16 or later. 11.2.0 through 11.2.4-h* Upgrade to 11.2.4-h22 or 11.2.16 or later. PAN-OS 11.1 11.1.14 through 11.1.16-h* Upgrade to 11.1.16-h3 or later. 11.1.11 through 11.1.13-h* Upgrade to 11.1.13-h15 or 11.1.16-h3 or later. 11.1.8 through 11.1.10-h* Upgrade to 11.1.10-h35 or 11.1.16-h3 or later. 11.1.7 through 11.1.7-h* Upgrade to 11.1.7-h11 or 11.1.16-h3 or later. 11.1.5 through 11.1.6-h* Upgrade to 11.1.6-h39 or 11.1.16-h3 or later. 11.1.0 through 11.1.4-h* Upgrade to 11.1.4-h37 or 11.1.16-h3 or later. PAN-OS 10.2 10.2.17 through 10.2.18-h* Upgrade to 10.2.18-h12 or later. 10.2.14 through 10.2.16-h* Upgrade to 10.2.16-h11 or 10.2.18-h12 or later. 10.2.11 through 10.2.13-h* Upgrade to 10.2.13-h26 or 10.2.18-h12 or later. 10.2.8 through 10.2.10-h* Upgrade to 10.2.10-h41 or 10.2.18-h12 or later. 10.2.0 through 10.2.7-h* Upgrade to 10.2.7-h38 or 10.2.18-h12 or later.
Workaround: No known workarounds exist for this issue. Customers with a Threat Prevention subscription are provided with limited coverage against this vulnerability by enabling Threat ID 510046 and 510047 (from Applications and Threats content version 9159-10287 and later). For these Threat IDs to protect against attacks for this vulnerability: * Route incoming traffic for the MGT port through a DP port https://docs.paloaltonetworks.com/best-practices/10-1/administrative-access-best-practices/administrative-access-best-practices/deploy-administrative-access-best-practices#id59206398-3dab-4b2f-9b4b-7ea500d036ba , e.g., enabling management profile on a DP interface for management access. * Replace the Certificate for Inbound Traffic Management https://docs.paloaltonetworks.com/best-practices/10-1/administrative-access-best-practices/administrative-access-best-practices/deploy-administrative-access-best-practices#id112f7714-8995-4496-bbf9-781e63dec71c . * Decrypt inbound traffic to the management interface so the firewall can inspect it https://docs.paloaltonetworks.com/best-practices/10-1/administrative-access-best-practices/administrative-access-best-practices/deploy-administrative-access-best-practices#idbbd82587-17a2-42b4-9245-d3714e1e13a2 . * Enable threat prevention on the inbound traffic to management services. Please note that this Threat ID requires SSL Decryption.
Exploitation: Very limited exploitation has been observed targeting the Palo Alto Networks management interface.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- CISA KEV catalog (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-0322)Record last updated .