Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-15810

Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover

High8.7EPSS 0.45%
Published
Updated
Reserved
Assigned by
GoogleCloud

Description

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

Scores

CVSS scores of CVE-2026-15810, by who scored it
Scored byCVSSScoreVector
GoogleCloudCNA (assigner)4.0High8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber
NVDNVD · Awaiting Analysis4.0High8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Amber
EPSS (exploitation in 30 days)
0.45% · top 60% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.7.

Weakness

Affected products

  • Google Cloud · Looker

    • affected < 25.6.103
    • affected < 25.12.65
    • affected < 25.18.68
    • affected < 26.0.66
    • affected < 26.2.47
    • affected < 26.4.36
    • affected < 26.6.28
    • affected < 26.8.7
  • Google Cloud · Looker

    • affected < 25.6.103
    • affected < 25.12.65
    • affected < 25.18.68
    • affected < 26.0.66
    • affected < 26.2.47
    • affected < 26.4.36
    • affected < 26.6.28
    • affected < 26.8.7

What to do

Solution: This vulnerability has been mitigated for Looker-hosted instances, and no user action is required. For Self-hosted Looker instances, customers should upgrade to one of the patched versions or later: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

References (2)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-15810 badge
[![CVE-2026-15810](https://trackcve.app/badge/CVE-2026-15810.svg)](https://trackcve.app/cve/CVE-2026-15810)

Record last updated .