CVE-2026-2052
Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic
- Published
- Updated
- Reserved
- Assigned by
- Wordfence
Description
The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| WordfenceCNA (assigner) | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Deferred | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.77% · top 44% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.8.
Weakness
Affected products
marketingfire · Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets
- affected ≤ 4.2.2
Marketing Fire, LLC · Widget Options - Extended
- affected ≤ 5.3.2
References (6)
- https://www.wordfence.com/threat-intel/vulnerabilities/id/68023557-fc92-4cf6-96b4-405ff5a5fd5a?source=cve (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/widgets/gutenberg/gutenberg-toolbar.php#L843 (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L495 (opens in a new tab)
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L534 (opens in a new tab)
- https://plugins.trac.wordpress.org/changeset/3481338/ (opens in a new tab)
- https://plugins.trac.wordpress.org/changeset/3514411/ (opens in a new tab)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-2052)Record last updated .