Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-23643

CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

Medium5.4EPSS 0.28%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

Scores

CVSS scores of CVE-2026-23643, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1Medium5.4CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
NVDNVD · Analyzed3.1Medium5.4CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS (exploitation in 30 days)
0.28% · top 79% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: poc · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.4.

Weakness

Affected products

  • cakephp · cakephp

    • affected >= 5.2.10, < 5.2.12
    • affected >= 5.3.0, < 5.3.1

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (6)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-23643 badge
[![CVE-2026-23643](https://trackcve.app/badge/CVE-2026-23643.svg)](https://trackcve.app/cve/CVE-2026-23643)

Record last updated .