Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-29146

Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

High7.5EPSS 8.8%
Published
Updated
Reserved
Assigned by
apache

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Scores

CVSS scores of CVE-2026-29146, by who scored it
Scored byCVSSScoreVector
CISA-ADPADP (enrichment)3.1High7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
redhat-SADPADP (enrichment)3.1High7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
NVDNVD · Modified3.1High7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS (exploitation in 30 days)
8.8% · top 4.8% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: yes · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.5.

Weakness

Affected products

  • Apache Software Foundation · Apache Tomcat

    • affected 11.0.0-M1 – ≤ 11.0.18
    • affected 10.0.0-M1 – ≤ 10.1.52
    • affected 9.0.13 – ≤ 9.0.115
    • affected 8.5.38 – ≤ 8.5.100
    • affected 7.0.100 – ≤ 7.0.109

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (20)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-29146 badge
[![CVE-2026-29146](https://trackcve.app/badge/CVE-2026-29146.svg)](https://trackcve.app/cve/CVE-2026-29146)

Record last updated .