CVE-2026-33229
XWiki Platform affected by remote code execution with script right through unprotected Velocity scripting API
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 4.0 | High8.6 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N |
| CISA-ADPADP (enrichment) | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Analyzed | 4.0 | High8.6 | CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.55% · top 54% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: yes · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.6.
Weakness
Affected products
- affected >= 17.0.0-rc-1, < 17.4.8
- affected >= 17.5.0-rc-1, < 17.10.1
org.xwiki.platform · xwiki-platform-legacy-oldcore
- affected >= 17.0.0-rc-1, < 17.4.8
- affected >= 17.5.0-rc-1, < 17.10.1
org.xwiki.platform · xwiki-platform-oldcore
- affected >= 17.0.0-rc-1, < 17.4.8
- affected >= 17.5.0-rc-1, < 17.10.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.xwiki.platform:xwiki-platform-legacy-oldcoreGHSA-h259-74h5-4rh9 (opens in a new tab)
- Mavenorg.xwiki.platform:xwiki-platform-oldcoreGHSA-h259-74h5-4rh9 (opens in a new tab)
References (4)
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h259-74h5-4rh9 (opens in a new tab)x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/9fe84da66184c05953df9466cf3a4acd15a46e63 (opens in a new tab)x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-23698 (opens in a new tab)x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-23702 (opens in a new tab)x_refsource_MISC
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-h259-74h5-4rh9 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-33229)Record last updated .