Back
CVE-2026-6437
AWS EFS CSI Driver Mount Option Injection
Medium6.9EPSS 0.56%
- Published
- Updated
- Reserved
- Assigned by
- AMZN
Description
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| AMZNCNA (assigner) | 4.0 | Medium6.9 | CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:H/SI:N/SA:N |
| AMZNCNA (assigner) | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N |
| NVDNVD · Modified | 4.0 | Medium6.9 | CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.56% · top 53% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.9.
Weakness
Affected products
- affected < 3.0.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Gogithub.com/kubernetes-sigs/aws-efs-csi-driverGHSA-mph4-q2vm-w2pw (opens in a new tab)
References (3)
- https://aws.amazon.com/security/security-bulletins/2026-016-aws/ (opens in a new tab)vendor-advisory
- https://github.com/kubernetes-sigs/aws-efs-csi-driver/security/advisories/GHSA-mph4-q2vm-w2pw (opens in a new tab)third-party-advisory
- https://github.com/kubernetes-sigs/aws-efs-csi-driver/releases/tag/v3.0.1 (opens in a new tab)patch
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-mph4-q2vm-w2pw (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-6437)Record last updated .