CVE-2026-7860
Possible information disclosure of environment variables in Vaadin Build Plugins via Failed Frontend Build
- Published
- Updated
- Reserved
- Assigned by
- Vaadin
Description
A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 23.0.0 - 23.6.9 Vaadin 24.0.0 - 24.9.16 Vaadin 24.10.0 - 24.10.3 Vaadin 25.0.0 - 25.0.10 Vaadin 25.1.0 - 25.1.4 Mitigation Upgrade to 23.6.10 Upgrade to 24.9.17 or newer Upgrade to 24.10.4 or newer Upgrade to 25.0.11 or newer Upgrade to 25.1.5 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version. ArtifactsMaven coordinatesVulnerable versionsFixed versioncom.vaadin:flow-plugin-base23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-plugin-base24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-plugin-base24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-plugin-base25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-plugin-base25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-maven-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-maven-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-maven-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-maven-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-maven-plugin25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-gradle-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-gradle-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-gradle-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-gradle-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-gradle-plugin25.1.0 - 25.1.4≥25.1.5
Timeline
ID reserved
By Vaadin
- 14 days later
· 14 days later
Published
- 4 months later
· 4 months later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VaadinCNA (assigner) | 4.0 | Low1.6 | CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/S:N/AU:N/R:A/V:C/RE:L/U:Green |
| NVDNVD · Awaiting Analysis | 4.0 | Low1.6 | CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:N/R:A/V:C/RE:L/U:Green |
- EPSS (exploitation in 30 days)
- 0.12% · top 98% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 1.6.
Weakness
Affected products
- affected 23.0.0 – ≤ 23.6.10
- affected 24.0.0 – ≤ 24.9.17
- affected 24.10.0 – ≤ 24.10.3
- affected 25.0.0 – ≤ 25.0.11
- affected 25.1.0 – ≤ 25.1.4
- affected 23.0.0 – ≤ 23.6.10
- affected 24.0.0 – ≤ 24.9.17
- affected 24.10.0 – ≤ 24.10.3
- affected 25.0.0 – ≤ 25.0.11
- affected 25.1.0 – ≤ 25.1.4
- affected 23.0.0 – ≤ 23.6.10
- affected 24.0.0 – ≤ 24.9.17
- affected 24.10.0 – ≤ 24.10.3
- affected 25.0.0 – ≤ 25.0.11
- affected 25.1.0 – ≤ 25.1.4
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavencom.vaadin:flow-gradle-pluginGHSA-j8mx-j73w-9mxw (opens in a new tab)
- Mavencom.vaadin:flow-maven-pluginGHSA-j8mx-j73w-9mxw (opens in a new tab)
- Mavencom.vaadin:flow-pluginsGHSA-j8mx-j73w-9mxw (opens in a new tab)
What to do
Solution: Users of affected versions should apply the following mitigation or upgrade.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-j8mx-j73w-9mxw (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-7860)Record last updated .