Skip to content
TrackCVE
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-85185

Path traversal in LXD btrfs storage driver allows arbitrary file deletion and write on host as root

Critical9.6Public exploitEPSS 0.37%
Published
Updated
Reserved
Assigned by
canonical

Description

Path traversal in the btrfs storage driver in Canonical LXD versions 4.0.2 and later (fixed in 4.0.14, 5.0.10, 5.21.8 and 6.10) on Linux allows an authenticated client with permission to create instances in a project to delete arbitrary files on the host as root. On hosts whose root filesystem is btrfs, the client can also place attacker-controlled content at arbitrary host paths, leading to full host compromise. The client does this with a crafted subvolume path containing ../ sequences, sent in either of two ways: in the optimized_header.yaml of an optimized btrfs backup, or in the btrfs migration header sent by a malicious migration source.

Public exploit

An exploit or proof of concept is public: anyone can try it against an unpatched system. CISA's SSVC rates its exploitation: a proof of concept is public.

Timeline

  1. ID reserved

    By canonical

  2. · 25 days later

    Published

Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.

Scores

CVSS scores of CVE-2026-85185, by who scored it
Scored byCVSSScoreVector
canonicalCNA (assigner)3.1Critical9.6CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
NVDNVD · Deferred3.1Critical9.6CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
EPSS (exploitation in 30 days)
0.37% · top 69% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: poc · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.6.

Weakness

Affected products

  • Canonical · LXD

    • affected 4.0.2 – < 4.0.14
    • affected 5.0.0 – < 5.0.10
    • affected 5.21.0 – < 5.21.8
    • affected 6.0 – < 6.10

What to do

Solution: Upgrade to LXD versions 4.0.14, 5.0.10, 5.21.8, 6.10 or later.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-85185 badge
[![CVE-2026-85185](https://trackcve.app/badge/CVE-2026-85185.svg)](https://trackcve.app/cve/CVE-2026-85185)

Record last updated .