Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-85706

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab

Critical10.0Known exploitedEPSS 97.4%
Published
Updated
Reserved
Assigned by
GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.7 before 18.11.12, 19.0 before 19.0.9, 19.1 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions, an unauthenticated user could have read arbitrary files from the GitLab server due to improper path confinement and missing authentication enforcement in the repository commits API.

Exploited in the wild

CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as GitLab Community Edition and Enterprise Edition Path Traversal Vulnerability.

Added
11 Sept 2026
Fix due (US federal)
14 Sept 2026
Used by ransomware
Not known

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Scores

CVSS scores of CVE-2026-85706, by who scored it
Scored byCVSSScoreVector
GitLabCNA (assigner)3.1Critical10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
NVDNVD · Analyzed3.1Critical10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS (exploitation in 30 days)
97.4% · top 0.1% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: active · Automatable: yes · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 10.0.

Weakness

Affected products

  • GitLab · GitLab

    • affected 18.7 – < 18.11.12
    • affected 19.0 – < 19.0.9
    • affected 19.1 – < 19.1.8
    • affected 19.2 – < 19.2.6
    • affected 19.3 – < 19.3.2

What to do

Solution: Upgrade to versions 18.11.12, 19.0.9, 19.1.8, 19.2.6, 19.3.2 or above.

References (3)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-85706 badge
[![CVE-2026-85706](https://trackcve.app/badge/CVE-2026-85706.svg)](https://trackcve.app/cve/CVE-2026-85706)

Record last updated .