CVE-2026-90580
FlowiseAI Flowise Evaluations Endpoint index.ts axios.post server-side request forgery
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability was found in FlowiseAI Flowise up to 3.0.2. This vulnerability affects the function axios.post of the file packages/server/src/controllers/evaluations/index.ts of the component Evaluations Endpoint. The manipulation of the argument Host/X-Forwarded-Proto results in server-side request forgery. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.1.3 is able to resolve this issue. The patch is identified as 700137738bcaebefd4709021f6d6b0abcd7df0ac. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 4.0 | Medium5.3 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P |
| VulDBCNA (assigner) | 3.1 | Medium6.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C |
| VulDBCNA (assigner) | 3.0 | Medium6.3 | CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C |
| VulDBCNA (assigner) | 2.0 | Medium6.5 | AV:N/AC:L/Au:S/C:P/I:P/A:P/E:POC/RL:OF/RC:C |
| NVDNVD · Analyzed | 4.0 | Low2.1 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X |
- EPSS (exploitation in 30 days)
- 0.41% · top 65% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.3.
Weakness
Affected products
References (8)
- VDB-403165 | FlowiseAI Flowise Evaluations Endpoint index.ts axios.post server-side request forgery (opens in a new tab)vdb-entrytechnical-description
- VDB-403165 | CTI Indicators (IOB, IOC, IOA) (opens in a new tab)signaturepermissions-required
- CVE-2026-90580 | CVE Analysis and Report (opens in a new tab)third-party-advisory
- Submit #913327 | FlowiseAI Flowise 3.0.1 => affected<=3.0.2 SSRF (opens in a new tab)third-party-advisory
- https://github.com/FlowiseAI/Flowise/issues/6687 (opens in a new tab)exploitissue-tracking
- https://github.com/FlowiseAI/Flowise/commit/700137738bcaebefd4709021f6d6b0abcd7df0ac (opens in a new tab)patch
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.3 (opens in a new tab)patch
- https://github.com/FlowiseAI/Flowise/ (opens in a new tab)product
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2026-90580)Record last updated .