Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2026-97229

Integer Overflow or Wraparound in GitLab

Critical10.0Known exploitedEPSS 65.2%
Published
Updated
Reserved
Assigned by
GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

Exploited in the wild

CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound Vulnerability.

Added
29 Oct 2026
Fix due (US federal)
1 Nov 2026
Used by ransomware
Not known

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Scores

CVSS scores of CVE-2026-97229, by who scored it
Scored byCVSSScoreVector
GitLabCNA (assigner)3.1Critical10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
NVDNVD · Analyzed3.1Critical10.0CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS (exploitation in 30 days)
65.2% · top 0.7% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: active · Automatable: yes · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 10.0.

Weakness

Affected products

  • GitLab · GitLab

    • affected 19.2 – < 19.2.8
    • affected 19.3 – < 19.3.5
    • affected 19.4 – < 19.4.2

What to do

Solution: Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.

References (7)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2026-97229 badge
[![CVE-2026-97229](https://trackcve.app/badge/CVE-2026-97229.svg)](https://trackcve.app/cve/CVE-2026-97229)

Record last updated .